Personalizzare il GSAK

Il GSAK consente all'utente di gestire un'ampia gamma di opzioni, che ne ottimizzano l'uso in base alle esigenze specifiche.

Settare alcune preferenze del programma è piuttosto veloce, e il risultato è quello di poter gestire al meglio i propri database, con un grosso risparmio di tempo.

Di seguito sono riportati i passaggi per svolgere alcune delle operazioni più elementari e di maggiore utilità.


Modificare le impostazioni di visualizzazione

Il GSAK all'avvio propone una videata (Grid View) standard, organizzata per righe orizzontali corrispondenti ai singoli cache e colonne verticali, ognuna delle quali raggruppa un'informazione specifica dei cache.
Molti degli elementi della Grid View, possono essere personalizzati in base alle proprie esigenze e ai gusti personali. Vediamo come.

Riorganizzare la disposizione delle colonne

E' possibile spostare a piacimento le colonne e ridisporle nell'ordine preferito. Questa operazione può tornare utile quando si vuole tenere d'occhio più velocemente qualche informazione, che per default viene invece visualizzata nelle ultime colonne. Quando i dati visibili sono numerosi, dobbiamo per forza di cose utilizzare la barra di scorrimento orizzontale, a meno che non portiamo a sinistra le colonne che vogliamo mantenere sempre visibili.
Il riordino viene effettuato attraverso una serie di classici "drag and drop", ossia di "trascinamenti", dopo aver selezionato l'intestazione della colonna da spostare e mantenendo premuto il pulsante sinistro del mouse.

Qusto stesso sistema può essere utilizzato per variare la larghezza delle colonne. In questo caso ci si dovrà posizionare sempre nell'intestazione, ma sul bordo destro della colonna che si vuole ridimensionare.

Aggiungere o rimuovere le colonne

Le informazioni che possono essere visualizzate attraverso le colonne sono 32. In realtà il GSAK ne mostra solo alcune, che corrispondono alle informazioni più importanti. Su questo aspetto possiamo intervenire selezionando l'opzione "Add/Delete Columns" dal menù "View" (vedi anche la sezione "Come iniziare").

2101392831_e2bd1ffaf1_o.jpg 2101393967_7092ab0562_o.jpg

Come abbastanza intuibile dalla foto in alto a destra, per aggiungere delle colonne basta "spuntare" la relativa casellina, per eliminarle è invece sufficiente togliere la "spunta".

Dopo aver dato l'Ok, come al punto precedente è possibile ridimensionare e riordinare le colonne a piacimento.

Salvare e utilizzare diverse impostazioni di visualizzazione

Prendendo confidenza con il GSAK è possibile che a seconda delle operazioni che si vogliono effettuare, sia più funzionale visualizzare determinate colonne in un ordine preciso, piuttosto che altre. Riarrangiare tutte le volte la tebella diventerebbe troppo brigoso e porterebbe via troppo tempo. Il programma permette di impostare i parametri di visualizzazione e di salvare diversi set da richiamare all'occorrenza, semplicemente selezionandoli.
La prima cosa da fare è ovviamente quella di decidere cosa rendere visibile nella Grid View e in quale ordine. Una volta impostati i parametri è sufficiente selezionare l'opzione "Save Current View" dal menù "View" e attribuirvi un nome che rimandi facilmente all'uso per cui è stata creata. Avendo a disposizione diversi set, è possibile quindi richiamarli velocemente attraverso lo stesso menù "View" selezionando l'opzione "Select View". Se in seguito si vorranno modificare alcune impostazioni, basterà farlo sulle schermate selezionate che verranno poi salvate nuovamente utilizzando lo stesso nome.

Personalizzare la Speedbar

La Speedbar è la barra immediatamente al di sotto di quella dei menù, caratterizzata dalla presenza di pulsanti. Consente di accedere velocemente ad alcune delle funzioni del GSAK, senza passare attraverso le scelte progressive che impongono i menù a tendina.
Anche questa sezione della videata può essere personalizzata a seconda delle esigenze, come accade per le colonne.
Per poter accedere alla funzione di personalizzazione, è necessario portare il cursore all'altezza della barra, premere il pulsante destro del mouse e selezionare l'opzione "Costomize Tool Bottons". A questo punto succederanno due cose:

  1. sarà possibile posizionarsi sui pulsanti da spostare e con la funzione "drag and drop" (vedi più in alto) muoverli orizontalmente;
  2. dalla finestra di dialogo che apparirà sarà invece possibile, utilizzando lo stesso sitema, trascinare nuovi pulsanti nella posizione voluta. Sulla sinistra sono elencate le funzioni, mentre sulla destra i pulsanti disponibili per l'azione selezionata.

Nel caso si volesse tornare alle impostazioni di partenza, attraverso il menù che appare premendo il pulsante destro del mouse sulla Speedbar, è sempre possibile selezionare l'opzione "Reset Default Buttons and Layout".

Personalizzare la barra di ricerca

Immediatamente sotto alla "Speedbar" si trova quella che viene definita "Search Bar", ossia barra per le ricerche. Per intenderci è quella costituita da una serie di caselline vuote, o datate di scelte multiple attivabili attraverso un menù a tendina, che consentono di effetturare delle ricerche nel database.
Anche in questo caso è possibile apportare qualche ritocco, in base alle esigenze di utilizzo. In particolare, attraverso la funzione "Customize Search Bar", che appare sempre premendo il pulsante destro del mouse con il cursore sulla barra, verrà attivata una finestra di opzioni dalla quale sarà possibile scegliere quali tipi di ricerca rendere visibili. Quando il pop up è attivo, è anche possibile modificare la grandezza e la disposizione delle caselle con la solita funzione drag and drop.
Attenzione! Quando lavorate su questa barra le modifiche apportate con i ridimensionamenti e gli spostamenti non vengono corrette dal programma, per cui se andate a coprire pulsanti e/o caselle, una volta tornati alla visualizzazione normale è possibile che alcune funzioni rimangano sovrapposte e non completamente visibili.

Atre opzioni di personalizzazione

Oltre a quelle menzionate, il GSAK permette di effettuare diverse altre personalizzazioni del programma, che possono essere molto utili per velocizzare le operazioni di routine. Per accedere a queste funzioni è necessario attivare la finestra di dialogo attraverso la voce "Options…" del menù "Tools", oppure premendo il relativo pulsante nella Speedbar (quello con l'icona del martelletto e della chiave inglese), se visibile nella barra (vedi "Personalizzare la Speedbar"). Il pop up che appare, è composto da una serie di tab. Di seguito i tab principali verranno analizzati singolarmente in maniera sintetica.

interlinea

2105527127_847dcceb1a.jpg?v=0

interlinea

Personalizzazione delle opzioni generali

interlinea

  • Default Action When You Double Click on a Waypoint Name - Il menù a tendina permette di scegliere fra 19 azioni che il programma può effettuare quando si esegue un doppio click su un cache. E' possibile ad esempio scegliere che il GSAK mostri la posizione del cache attraverso un servizio di mappe on line a scelta fra quelle disponibili, se questa è l'operazione svolta più frequentemente.
  • Method for matching placed (hidden) and found caches - Il contenuto di questa casella è fondamentale in quanto identifica chi utilizza il programma in maniera univoca ed è usato dal GSAK per alcune delle sue funzioni (ad esempio per individuare i cache nascosti dal proprietario). E' possibile utilizzare diversi metodi per l'identificazione, ma quello consigliato è l'uso dell'ID. Per trovare l'ID vedi sezione "Caricare il database su GSAK". Non dimenticate di selezionare anche la voce "Use gc.com logon ID#".
  • Status Attributes - Consente di intervenire sul colore con il quale verranno indicati i propri cache, quelli trovati e non trovati dall'utente del GSAK e quelli non disponibili. E' possibile settare anche la priorità del colore da visualizzare nel caso coesistano più condizioni contemporaneamente: ad esempio un nostro cache al momento non disponibile (come visibile dalla foto più in alto, la priorità più alta è "1", quella più bassa è "4"). Infine è possibile stabilire se il colore debba evidenziare il waypoint, o la prima colonna a sinistra, indipendentemete dall'informazione che contiene.

Personalizzazione dell'HTML

Da qui è possibile, fra le altre cose, personalizzare il menù a tendina che si apre quando il cursore è su un cache e premendo il pulsante destro del mouse ci si porta alla voce "Custom URL".

2106414706_1cba1e2e4e_o.jpg

In questo set di opzioni si trova una serie di collegamenti a pagine Internet che possono essere attivate: ad esempio visualizzare il cache su Geocachin.com, oppure su una mappa on line, oppure andare direttamente alla pagina per inserire il log, ecc.
E' possibile intervenire su questi collegamenti eliminando quelli che non interessano, oppure aggiungendone di nuovi facendo attenzione al formato di inserimento (conviene fare qualche prova aggiungendo in fondo una nuova linea).

Personalizzazione delle abbreviazioni

  • Add Abbreviations - Consente di aggiungere o modificare le abbreviazioni dei nomi delle nazioni (o delle provincie per il Canada). Il formato da usare è il seguente: nome nazione (per intero)=abbreviazione (ad esempio: italia=IT). Stati Uniti, Canada e Australia hanno già delle abbreviazioni per default; per vederle è necessario selezionare la relativa bandierina.
  • Convert Abbreviations - Il GSAK permette di convertire i nomi degli stati in abbreviazioni o viceversa, quando viene importato un database. Questa funzione può essere utile se nella Grid View si vuole mantenere la colonna "Country", ma si vuole ridurre lo spazio occupato nello schermo, pur riuscendo ad individuare velocemente la nazione. Se si vuole utilizzare questa funzione, è necessario spuntare la casella "Convert (abbreviate) state names on import" e scegliere il tipo di conversione.

interlinea