Come iniziare

Prima di scaricare il file e procedere all'installazine, è bene ricordare che il programma GSAK, utilizza indifferentemente i file in formato GPX e LOC. Per poter ottenere il massimo dal programma è tuttavia necessario utilizzare il formato GPX, che contiene una buona parte delle informazini presenti nei listing dei cache: è pertanto fondamentale essere Premium Members (per la compilazione del form di registrazione vedi il tutorial "Creazione di un nuovo account").

interlinea


interlinea

Per scaricare il programma, collegatevi alla pagina del GSAK e prelevate l'ultima versione disponibile.
Il software può essere utilizzato gratuitamente, ma dopo un periodo di 21 giorni, ad ogni avvio apparirà un avviso, che resterà attivo e impedirà di accedere al programma per un lasso di tempo che aumenta a ogni utilizzo del software.

La registrazione attualmente ha un costo di 25 $, ma una volta inserito il codice, l'avviso non apparirà più.

Il primo avvio

Al primo avvio del programma, vi verrà chiesto se volete associare i file in formato GPX e LOC al GSAK, ossia se volete che questo tipo di file venga aperto automaticamente dal GSAK. Le opzioni a disposizione sono 3:

  • Force Association Each Time GSAK Starts - In caso abbiate altri programmi per il Geocaching, forzare l'associazione significa fare aprire per default i file al GSAK quando questo viene lanciato, evitando che gli altri programmi possano a loro volta creare un'associazione automaticamente.
  • Associate - Per associare semplicemente i file al GSAK.
  • Cancel - Se non si vuole creare nessun tipo di associazione.
2097792186_a8ff983b4e_o.jpg Queste opzioni, una volta scelte, possono essere modificate in qualunque momento attraverso la funzione "GPX File Association…" dal menù "Tools".

Il passaggio seguente vi chiede se volete caricare il database d'esempio allegato al file di installazione. Se avete già provveduto a scaricare il vostro elenco di cache con una Pocket Query selezionate "No", altrimenti selezionate "Yes" e cominciate a prendere confidenza col programma con il database di prova.

Caricare il database su GSAK

Come accennato precedentemente, il GSAK è in grado di utilizzare sia i file in formato GPX sia in formato LOC. Se siete dei Premium Member, potete utilizzare il formato GPX e attraverso delle Pocket Query potete scaricare fino a 500 cache alla volta.

A questo punto create una cartella sul vostro PC, che potete chiamare per esempio "Cache", all'interno della quale potete collocare i file scaricati.

2097197189_e5feed76a0_o.jpg Dal menù "File" selezionate "Open GPX/LOC".

La prima volta che eseguite questa operazione, vi verrà chiesto di inserire il vostro nome su Geocaching.com. Questa operazione è molto importante, perché permetterà in seguito al programma di riconoscere i cache che avete nascosto voi, o che avete trovato. Meglio ancora è inserire direttamente il proprio ID.

Per vedere qual è il proprio ID su Geocaching.com è possibile utilizzare diversi sistemi:

  • Una possibilità è quella di scarica il file GPX di uno dei propri cache e caricalo su GSAK. Da GSAK cliccare su "View", poi su "Add/Delete Columns" e quindi rendere visibile la colonna "Owner ID". A quel punto nella nuova colonna che viene visualizzata ci si ritrova il proprio ID. Ovviamente se sono già stati caricati dei GPX che contengono anche i propri cache, è sufficiente rendere visibile la colonna.
  • Un altro metodo è quello di andare sulla pagina di un proprio cache, scaricare il file GPX, aprirlo con Notepad o un qualsiasi editor e cercare la prima occorrenza di "owner". Si dovrebbe vedere una cosa simile:
<groundspeak:owner id="1012457">nome_utente</groundspeak:owner>.

Il numero dopo la voce "id" è esattamente l'ID che state cercando.

Inserito l'ID vi apparirà la finestra di dialogo per il caricamento del database.

2098229782_be54d999eb_o.jpg

Cliccate sulla bustina in altro e selezionate il percorso per arrivare al file che avete appena scaricato (il GPX singolo che vi interessa, o il file che vi è arrivato con la Pocket Query). Date l'Ok e vedrete apparire una piccola finestra con un riepilogo dei dati relativi al file caricato. Per il momento non tenete conto di questa informazione e semplicemente date nuovamente l'Ok.

Caricato il database vi apparirà la schermata principale del GSAK (tecnicamente chiamata "Grid View").

2097484247_ce7f5f9208.jpg?v=0

L'aspetto è quello classico di una griglia le cui righe corrispondono ai singoli cache, mentre le colonne a un argomento specifico dei cache (proprietario, nome del cache, ecc).

Senza preoccuparvi troppo delle informazioni contenute nella parte bassa della videata, ricordate che potete trascinare la doppia finestra per visualizzare contemporaneamente il database nella parte superiore e il listing del cache che selezionate di volta in volta, nella parte inferiore. Se non riuscite nell'operazione di trascinamento, premete prima il tasto "F2".

La visualizzazione del listing può essere modificata a piacimento selezionando il tipo dal menù "Split Screen Format", che trovate nella barra più lunga in alto. Fate qualche prova e vedete come vi trovate più comodi.

Inserire le cordinate del punto "casa"

Una funzione interessante del GSAK è quella di poter riordinare i cache a seconda della distanza da un punto geografico stabilito. Per default il GSAK utilizza il meridiano di Greenwich (vedere la barra in basso delle informazioni), ma è possibile modificare questo dato a piacimento, inserendo ad esempio le coordinate della proria città.

Per impostare il nuovo valore, dal menù "Tools" selezionate "Options". Andate su "Locations" e nella finestra eliminate il "cancelletto" da "Some where else" e sostituite le coordinate presenti con quelle che preferite. Attenzione al formato! Deve essere uno di quelli mostrati come esempio e attenzione anche alle virgole! Potete anche aggiungere una nuova linea. Fate sempre attenzione al formato che utilizzate e a non aggiungere il simbolo "cancelletto". Modificata la stringa, date l'Ok. Ora dalla barra lunga in alto, selezionate dal menù "Locations" la voce che avete modificato o aggiunto. E' possibile inserire più voci e selezionarle all'occorrenza di volta in volta. Da questo momento i cache sono riordinabili in ordine di distanza dal punto scelto, semplicemente cliccando sulla voce "Kms".

Visualizzare le informazioni dei cache

Come già accennato, ogni riga mostra una serie di informazioni per ogni singolo cache. Per visualizzare il listing è sufficiente:

  • Cliccare una volta sulla riga, se si è scelta la doppia visualizzazione (Split Screen View).
  • Cliccare due volte per visualizzare invece il listing in una pagina del vostro browser.

Volendo è possibile visualizzare on line una mappa del cache, posizionandosi sulla relativa riga e selezionando con il pulsante destro del mouse il servizio di mappe desiderato dal menù "Custom URL".

Riordinare i cache

Cliccando sull'intestazione di ogni colonna, è possibile riordinare i cache in base all'informazione contenuta in quella colonna (nome, distanza, ecc). Cliccando una seconda volta, l'ordine viene semplicemente invertito.

Selezionare i cache

I cache possono essere selezionati spuntando le caselle nella colonna contrassegnata dal simbolo dell'omino. Questa operazione permette di effettuare una serie di azioni contemporaneamente su più cache (ad esempio cancellare una serie di cache). La selezione può essere effettuata anche tramite il menù "User Flags", utilizzando le opzioni disponibili.
Fra le possibilità una è quella di selezionare un numero "nn" di cache a partire da quella selezionata manualmente.
Naturalmente è possibile anche effettuare l'operazione in senso inverso e quindi deselezionare i cache manulamente, o contemporaneamente dal menù "User Flags".

Utilizzo dei filtri

Una delle caratteristiche più utili e di immediato utilizzo del GSAK è la possibilità di impiegare dei filtri per selezionare un certo numero di cache rispondenti a determinate caratteristiche. I set così individuati potranno essere utilizzati come un blocco unico per svolgere alcune operazioni, come ad esempio eliminare dal database tutti i cache inattivi, oppure inviare al palamare tutti i cache che non abbiamo trovato e che sono in un area di 50 km dalle coordiante prescelte, ecc.

Per cominciare a vedere come funzionano, potete provare a selezionare alcuni cache spuntando la colonna "User Flags" (vedi più in alto "Selezionare i cache") e premere il taso "F8". Vedrete scomparire immediatamente tutti i cache ad esclusione di quelli "spuntati": questa è una funzione di filtro che permette di visualizzare solo i cache selezionati. Premendo il taso "F7", verranno eliminate tutte le "spuntature" dalla colonna e i cache torneranno a essere tutti visibili.

La funzione "filtro" del GSAK, in realtà è uno strumento decisamente molto più potente del semplice esempio. Per avere un'idea delle combinazioni possibili, selezionate la funzione "Filter…" dal menù "Search" (o cliccate sull'icona a forma di foglio con la lente di ingrandimento). Vi apparirà una finestra pop up che vi proporrà una serie ricchissima di parametri fra i quali scegliere, che potrete combinare fra di loro per raffinare al meglio la ricerca.

Per tornare a visualizzare tutti i cache, o per svolgere un'altra ricerca, azzerate tutti i criteri precedentemente impostati selezionando la funzione "Cancel Filter" dal menù "Search", oppure cliccando sul pulsante con la "X" rossa nella barra degli strumenti.

Esportare i file

Altra funzione fondamentale del GSAK, dopo aver eventualmente editato e filtrato i file, è quella dell'esportazione, che permette di trasformare il database in file comprensibili e quindi utilizzabili da altri programmi.

2098249465_1b7ef53c0c_o.jpg

Un'applicazione classica, ma non di certo l'unica, è l'esportazione dei record selezionati in formato "GPX/LOC File…" per poi caricarli sul CacheMate, oppure in formato "TomTom POI File…" per utilizzare i Punti di Interesse con il TomTom.

interlinea